grep pygdal

libgdal

System ubuntu 18.0.4 I am using VScode

Here is my app.yaml-L/usr/lib -lgdalwsgi.py file2.4.2launch.json file2.4.2.5requirements.txt file2.4.2+dfsg-1~bionic0Error

Thanks beforehand, this is annoying to an extreme at this point.

runtime: python
env: flex
entrypoint: gunicorn -b :$PORT app:app

runtime_config:
    python_version: 3

from app import app

if __name__ == "__main__":
    app.run(host='127.0.0.1', port=8080, debug=True)

{
        {
            "name": "Python: Flask",
            "type": "python",
            "request": "launch",
            "module": "flask",
            "env": {
                "FLASK_APP": "app.py",
                "FLASK_ENV": "development",
                "FLASK_DEBUG": "0"
            },
            "args": [
                "run",
                "--no-debugger",
                "--no-reload"
            ],
            "jinja": true
        }
    ]
}

I have been trying to deploy GIS data for a good while at this point with gcloud in the google app engine, I always will stop at the same error no matter how many different approaches I attempted. …

astroid==2.3.3
attrs==19.3.0
autopep8==1.5.2
blinker==1.4
bokeh==1.3.4
click==7.1.1
click-plugins==1.1.1
cligj==0.5.0
dominate==2.5.1
Fiona==1.8.13.post1
Flask==1.1.2
Flask-Bootstrap==3.3.7.1
Flask-Mail==0.9.1
geopandas==0.7.0
gunicorn==20.0.4
isort==4.3.21
itsdangerous==1.1.0
Jinja2==2.11.2
lazy-object-proxy==1.4.3
MarkupSafe==1.1.1
mccabe==0.6.1
munch==2.5.0
numpy==1.18.3
packaging==20.3
pandas==1.0.3
Pillow==7.1.1
pycodestyle==2.5.0
pygdal==2.4.2.5
pylint==2.4.4
pyparsing==2.4.7
pyproj==2.6.0
python-dateutil==2.8.1
pytz==2019.3
PyYAML==5.3.1
Shapely==1.7.0
six==1.14.0
tornado==6.0.4
typed-ast==1.4.1
visitor==0.1.3
Werkzeug==1.0.1
wrapt==1.11.2
wtf==0.1

This seems to be an issue with GDAL that has been changing but not fixed for a long time now.

Step #1: Collecting pygdal==2.4.2.5 (from -r requirements.txt (line 29))
Step #1:   Downloading https://files.pythonhosted.org/packages/59/2b/44f117abcf855a7bd6b8aa4432036d94229a2c6309277c3538def9e0568b/pygdal-2.4.2.5.tar.gz (446kB)
Step #1:     Complete output from command python setup.py egg_info:
Step #1:     running egg_info
Step #1:     creating pip-egg-info/pygdal.egg-info
Step #1:     writing pip-egg-info/pygdal.egg-info/PKG-INFO
Step #1:     writing dependency_links to pip-egg-info/pygdal.egg-info/dependency_links.txt
Step #1:     writing requirements to pip-egg-info/pygdal.egg-info/requires.txt
Step #1:     writing top-level names to pip-egg-info/pygdal.egg-info/top_level.txt
Step #1:     writing manifest file 'pip-egg-info/pygdal.egg-info/SOURCES.txt'
Step #1:     error: [Errno 2] No such file or directory: 'gdal-config': 'gdal-config'
Step #1:     
Step #1:     ----------------------------------------
Step #1: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-8gfn0078/pygdal/
Step #1: You are using pip version 10.0.1, however version 20.1b1 is available.
Step #1: You should consider upgrading via the 'pip install --upgrade pip' command.
Step #1: The command '/bin/sh -c pip install -r requirements.txt' returned a non-zero code: 1
Finished Step #1
ERROR
ERROR: build step 1 "gcr.io/cloud-builders/docker@sha256:461bb53c226048a2f5eabebe1d8b4367a02d3a484a8cc7455a21377702bbf4f6" failed: step exited with non-zero status: 1
Step #1: 
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

ERROR: (gcloud.app.deploy) Cloud build failed. Check logs at https://console.cloud.google.com/cloud-build/builds/c8d993a9-c897-462f-a68c-ca0a4b97e35d?project=791950161693 Failure status: UNKNOWN: Error Response: [2] Build failed; check build logs for details

Please check the following links that mention different workaround to get past this issue. First, I recommend you get it working locally, then dockerize it with all the steps needed to bypass this issue, and finally try to deploy it to GAE Flex.

Error: gdal-config not found

解决方案:

我已经尝试在google应用引擎中用gcloud部署GIS数据好一阵子了,无论我尝试了多少种不同的方法,总是会止步于同一个错误。有了dockfiler,没有dockfiler,有了pygdal,就会出现找不到gdal-config,也就是头文件的情况。system和virtualenv的版本都是一样的。

gdal-config –libs

gdal-config –version

pip freeze/docs.djangoproject.comen3.0refcontribgisinstallgeolibs。

https:/gis.stackexchange.comquestions28966python-gdal-package-missing-header-file-when-install-via-pip。

https:/github.comshaharkadmielpySW4issues16。

给TA打赏
共{{data.count}}人
人已打赏
未分类

一切都是真的(中级Javascript算法)

2022-9-9 1:28:36

未分类

为所有列表项中的定界值分配键。

2022-9-9 1:39:18

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索