Angular Cli无法正常卸载

我的node版本是8.9.3,我的angular cli版本是8以上。由于不支持Angular CLI 8及以上版本。我试着把8以下的angular版本降级(比如7.3.5)。我无法更新node,我需要指定版本的node。为了降级angular cli,我首先卸载了当前的angular cli,然后安装了我想要的 cli 版本。安装好Cli后,ng –version抛出以下错误。

你运行的是Node.js的v8.9.3版本,Angular CLI 8.0+不支持这个版本。

官方支持的Node.js版本是10.9或更高版本。

请访问 https:/nodejs.orgen。 以找到如何更新Node.js的说明。

后来我访问了下面的链接,没有一个解决方案对我有效。

我试过的解决方案。

  1. 全局卸载使用 npm uninstall -g @angular/cli 指挥
  2. Npm缓存已清理并验证 npm cache clean --force npm cache verify
  3. 手动删除AppdataRoamingnpm中的cli文件夹。

enter image description here

解决方案:

由于你需要使用与你的节点版本相匹配的特定版本的angular cli,你可以通过以下方式来实现

该命令将安装1.0.0版本。

npm install -g @angular/cli@1.0.0

本文来自投稿,不代表实战宝典立场,如若转载,请注明出处:https://www.shizhanbaodian.com/16616.html

(0)
上一篇 1天前
下一篇 1天前

相关推荐

发表评论

登录后才能评论